API_​IPropertyDefinitionEventHandler

The base class you need to inherit from in case you want to handle API_PropertyDefinition events.

    class API_IPropertyDefinitionEventHandler : public API_IEventHandler {
    public:
        virtual void OnCreated (const GS::HashSet<API_Guid>& ids) const;
        virtual void OnModified (const GS::HashSet<API_Guid>& ids) const;
        virtual void OnDeleted (const GS::HashSet<API_Guid>& ids) const;
    };

 

Functions

OnCreated
Override this function to be notified of newly created Property Definitions.
OnModified
Override this function to be notified of modified Property Definitions.
OnDeleted
Override this function to be notified of deleted Property Definitions.

  

Requirements

Version: API 26 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Notify_RegisterEventHandler
API_PropertyDefinition,
API Types