API_​FTypeID

Available file format identifiers for automate functions.

    typedef enum {
        APIFType_None,
APIFType_PlanFile, APIFType_A_PlanFile, APIFType_Bak_PlanFile, APIFType_WGClientFile, APIFType_A_WGClientFile, APIFType_Bak_WGClientFile,
APIFType_PlanFile600, APIFType_A_PlanFile600, APIFType_PlanFile650, APIFType_A_PlanFile650, APIFType_PlanFile700, APIFType_A_PlanFile700,
APIFType_WGProjFile, APIFType_A_WGProjFile, APIFType_Bak_WGProjFile, APIFType_TabListFile, APIFType_ObjectFile, APIFType_DoorFile, APIFType_WindowFile, APIFType_GDLFile, APIFType_2DLinesFile,
APIFType_PNGFile, APIFType_BMPFile, APIFType_TIFFFile, APIFType_JPEGFile, APIFType_GIFFile,
APIFType_EMFFile, APIFType_WMFFile,
APIFType_PlanFile800, APIFType_A_PlanFile800, APIFType_PlanFile810, APIFType_A_PlanFile810, APIFType_PlanFile900, APIFType_A_PlanFile900, APIFType_PlanFile1000, APIFType_A_PlanFile1000, APIFType_PlanFile1100, APIFType_A_PlanFile1100, APIFType_PlanFile1200, APIFType_A_PlanFile1200,
APIFType_IfcFile,
APIFType_PlanFile1300, APIFType_A_PlanFile1300, APIFType_PlanFile1400, APIFType_A_PlanFile1400, APIFType_PlanFile1500, APIFType_A_PlanFile1500, APIFType_PlanFile1600, APIFType_A_PlanFile1600, APIFType_PlanFile1700, APIFType_A_PlanFile1700,
APIFType_PlanFile1800, APIFType_A_PlanFile1800,
APIFType_PdfFile,
APIFType_PlanFile1900, APIFType_A_PlanFile1900, APIFType_PlanFile2000, APIFType_A_PlanFile2000, APIFType_PlanFile2100, APIFType_A_PlanFile2100, APIFType_SafFile, APIFType_PlanFile2200, APIFType_A_PlanFile2200, APIFType_PlanFile2300, APIFType_A_PlanFile2300, APIFType_PlanFile2400, APIFType_A_PlanFile2400, APIFType_PlanFile2500, APIFType_A_PlanFile2500, APIFType_SafFile } API_FTypeID;

 

Members

APIFType_None
unknown file type
APIFType_PlanFile
Archicad Solo Project File
APIFType_A_PlanFile
Archicad Archive File
APIFType_Bak_PlanFile
Archicad Backup File
APIFType_WGClientFile
Archicad TeamWork Draft File
APIFType_A_WGClientFile
AC TeamWork Draft Archive File
APIFType_Bak_WGClientFile
AC TeamWork Draft Backup File
APIFType_PlanFile600
Archicad 6.0 Plan File
APIFType_A_PlanFile600
Archicad 6.0 Archive File
APIFType_PlanFile650
Archicad 6.5 Plan File
APIFType_A_PlanFile650
Archicad 6.5 Archive File
APIFType_PlanFile700
Archicad 7.0 Plan File
APIFType_A_PlanFile700
Archicad 7.0 Archive File
APIFType_WGProjFile
Archicad TeamWork Project File
APIFType_A_WGProjFile
AC TeamWork Project Archive
APIFType_Bak_WGProjFile
AC TeamWork Project Backup File
APIFType_TabListFile
Archicad List File with Tabs
APIFType_ObjectFile
Archicad Object File
APIFType_DoorFile
Archicad Door File
APIFType_WindowFile
Archicad Window File
APIFType_GDLFile
Archicad GDL File
APIFType_2DLinesFile
2D Lines File
APIFType_PNGFile API version 18
PNG File
APIFType_BMPFile
Bitmap File
APIFType_TIFFFile
TIFF File
APIFType_JPEGFile
JPEG File
APIFType_GIFFile
GIF File
APIFType_EMFFile
Windows Enhanced Metafile
APIFType_WMFFile
Windows Metafile
APIFType_PlanFile800 5.1
Archicad 8 Plan File
APIFType_A_PlanFile800 5.1
Archicad 8 Archive File
APIFType_PlanFile810 6.1
Archicad 8.1 Plan File
APIFType_A_PlanFile810 6.1
Archicad 8.1 Archive File
APIFType_PlanFile900 Featuring API 10
Archicad 9.0 Plan File
APIFType_A_PlanFile900 Featuring API 10
Archicad 9.0 Archive File
APIFType_PlanFile1000 11
Archicad 10.0 Plan File
APIFType_A_PlanFile1000 11
Archicad 10.0 Archive File
APIFType_PlanFile1100 12
Archicad 11.0 Plan File
APIFType_A_PlanFile1100 12
Archicad 11.0 Archive File
APIFType_PlanFile1200 13
Archicad 12.0 Plan File
APIFType_A_PlanFile1200 13
Archicad 12.0 Archive File
APIFType_IfcFile (save only) 11
IFC File
APIFType_PlanFile1300 14
Archicad 13 Plan File
APIFType_A_PlanFile1300 14
Archicad 13 Archive File
APIFType_PlanFile1400 15
Archicad 14 Plan File
APIFType_A_PlanFile1400 15
Archicad 14 Archive File
APIFType_PlanFile1500 16
Archicad 15 Plan File
APIFType_A_PlanFile1500 16
Archicad 15 Archive File
APIFType_PlanFile1600 17
Archicad 16 Plan File
APIFType_A_PlanFile1600 17
Archicad 16 Archive File
APIFType_PlanFile1700 18
Archicad 17 Plan File
APIFType_A_PlanFile1700 18
Archicad 17 Archive File
APIFType_PlanFile1800 19
Archicad 18 Plan File
APIFType_A_PlanFile1800 19
Archicad 18 Archive File
APIFType_PdfFile 17
PDF File
APIFType_PlanFile1900 20
Archicad 19 Plan File
APIFType_A_PlanFile1900 20
Archicad 19 Archive File
APIFType_PlanFile2000 21
Archicad 20 Plan File
APIFType_A_PlanFile2000 21
Archicad 20 Archive File
APIFType_PlanFile2100 22
Archicad 21 Plan File
APIFType_A_PlanFile2100 22
Archicad 21 Archive File
APIFType_SafFile New in API 25
SAF File
APIFType_PlanFile2200 23
Archicad 22 Plan File
APIFType_A_PlanFile2200 23
Archicad 22 Archive File
APIFType_PlanFile2300 24
Archicad 23 Plan File
APIFType_A_PlanFile2300 24
Archicad 23 Archive File
APIFType_PlanFile2400 25
Archicad 24 Plan File
APIFType_A_PlanFile2400 25
Archicad 24 Archive File
APIFType_PlanFile2500 New in API 26
Archicad 25 Plan File
APIFType_A_PlanFile2500 New in API 26
Archicad 25 Archive File
APIFType_SafFile New in API 26
SAF File

 

Remarks

For the utilization of this structure see the APIDo_OpenID and APIDo_SaveID automation functions.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Automate.h

 

See Also

APIDo_OpenID
APIDo_SaveID
API Types