API_​RoofRelation, API_​ShellRelation

Structure for retrieving connection data of a roof or a shell element.

    typedef struct {
        GS::Array<API_Guid>*                rooms; 
    } API_RoofRelation, API_ShellRelation;

 

Members

rooms
Array of guid of the rooms connected to the roof or shell.
filler
Reserved for further use.

 

Remarks

To learn more about the usage of this relation structure please refer to the ACAPI_Element_GetRelations function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetRelations, API_WallRelation, API_ConnectionGuidItem, API Types