ACAPI_​Element_​AddClassificationItemDefault

Classifies an element.

    GSErrCode  ACAPI_Element_AddClassificationItemDefault (
        const API_ElemType&         type,
        const API_Guid&             itemGuid
    );

 

Parameters

type
[in] Type of the default element.
itemGuid
[in] The guid of the classification item, that should be added to the element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The type did not refer to a valid default element or itemGuid did not refer to a valid classification item.
APIERR_READONLY
The element can not be modified (i.e. from a hotlink) or you do not have the right to classify elements in the current teamwork plan.
APIERR_BADCLASSIFICATION
The classification item is not available for the given element.

For other common API errors see the API Errors document.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions