ACAPI_​Resource_​GetFixStr

Reads a string from an ‘STRf‘ string list resource.

    bool  ACAPI_Resource_GetFixStr (
        char*           str,
        short           resID,
        short           index,
        GSResModule     resModule = ACAPI_GetOwnResModule ()
    );

 

Parameters

str
The pointer of the string.
resID
The resource ID of the ‘STRf‘ resource in the GRC file.
index
The index of the string in the resource.
resModule New in API 16
[in] The resource module to load the resource from. The default value is the add-on’s own resource module.

 

Return Values

true
The string was retrieved successfully.
false
The string wasn’t retrieved.

 

Remarks

This function is used to load a string from a string list resource, which is not required to localize.

The GRC compiler uses the ‘STRf‘ resource type for this purpose. The different lines in the resource will be the indices referenced by index parameter. For more information about the structure of the GRC file please refer to the GRC documentation.

 

Example

See the example of ACAPI_Resource_GetLocStr.

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Resource_GetLocStr, ACAPI_Resource_GetLocUStr,
Resource Manager, API Functions