ACAPI_​Attribute_​GetPropertyValue

Retrieves the property value of the property definition.

    GSErrCode  ACAPI_Attribute_GetPropertyValue (
        const API_Attr_Head&               attrHead,
        const API_Guid&     		   propertyDefinitionGuid,
        API_Property&                      property
    );

 

Parameters

attrHead
[in] Header of the attribute. The attribute is identified by typeID and index
propertyDefinitionGuid
[in] Property definition.
property
[out] Property value.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
The attrHead did not refer to a valid attribute.
APIERR_GENERAL
Every other case.

For other common API errors see the API Errors document.

 

Example


GSErrCode GetPropertyDefinitionNames (API_AttrTypeID attributeTypeID, short attributeIndex, GS::Array<GS::UniString>& names)
{
    API_Attr_Head                     attributeHeader;
    GS::Array<API_PropertyDefinition> definitions;
	
    BNZeroMemory (&attributeHeader, sizeof (API_Attr_Head));
    attributeHeader.typeID = attributeTypeID;
    attributeHeader.index = attributeIndex;
	
    GSErrCode error = ACAPI_Attribute_GetPropertyDefinitions (attributeHeader, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); i++) {
            API_Property property;
            BNZeroMemory (&property, sizeof (API_Property));

            error = ACAPI_Attribute_GetPropertyValue (attributeHeader, definitions [i], property);
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version:API 23 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions