ACAPI_​AnalyticalModel_​GetAnalyticalSupportGeometry

Returns the Structural AnalyticalSupport Geometry.

    GSErrCode  ACAPI_AnalyticalModel_GetAnalyticalSupportGeometry (
        const API_Guid&                   amGuid,
        const API_Guid&                   elemGuid,
        API_AnalyticalSupportGeometry&    api_analyticalSupportGeometry
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Curve Element.
api_analyticalSupportGeometry
[out] The Structural Analytical Support geometry.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions