ACAPI_​Element_​IsPropertyDefinitionVisibleDefault

Tells whether a property definition is visible for an element default.

    bool  ACAPI_Element_IsPropertyDefinitionVisibleDefault (
        const API_ElemType&     type,
        const API_Guid&         propertyGuid
    );

 

Parameters

type
[in] Type of the default element.
propertyGuid
[in] The property definition GUID to search for.

 

Return Values

true
The given property definition is visible for the element default.
false
The given property definition is not visible for the element default.

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example


GSErrCode GetVisiblePropertyDefinitions (const API_ElemType& type, GS::Array<API_PropertyDefinition>& visibleProperties)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); ++i) {
            if (ACAPI_Element_IsPropertyDefinitionVisibleDefault (type, definitions[i].guid)) {
                visibleProperties.Push (definitions[i]);
            }
        }
    }
    return error;
}
        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Properties, Classification and Property Visibility