API_​LegacyPrefs

The representation of the Preferences / Legacy tab page.

    typedef struct {
        Int32                      filler_1;
        Int32                      coluConnPriority;
        short                      filler_2;
        API_AttributeIndex         aboveLineType;
        API_AttributeIndex         belowLineType;
        short                      filler_3;
        API_RoofContourDisplay     roofContourDisplay;
        bool                       filler_4;
        bool                       useLegacyIntersections;
        char                       filler_5[2];
        Int32                      filler_6[12];
    } API_LegacyPrefs;

 

Members

coluConnPriority
priority factor for column intersection
aboveLineType 5.1
Line type index to be used for displaying construction elements above their home story
belowLineType 5.1
Line type index to be used for displaying construction elements below their home story
roofContourDisplay 15
Display the roof with all visible contours (APIRoofDisplay_AllVisibleContours), or the old way (APIRoofDisplay_OnlyTheTopSurfaceOldWay).

API_RoofContourDisplay

APIRoofDisplay_AllVisibleContours

APIRoofDisplay_OnlyTheTopSurfaceOldWay

useLegacyIntersections 20
Use legacy intersection and Surface methods for model elements

 

Remarks

This structure is used by the APIEnv_GetPreferencesID function to get the legacy preferences page.

The aboveLineType and belowLineType parameters are are only effective on Library Parts if the Use Symbol Linetypes checkbox in their Settings dialog boxes is switched off. They have no effect on Ghost Story elements.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetPreferencesID
API_AttributeIndex
API Types