ACAPI_​Classification_​GetClassificationSystemRootItems

Retrieves the root items of a classification system.

        GSErrCode  ACAPI_Classification_GetClassificationSystemRootItems (
            const API_Guid&                              systemGuid
            GS::Array<API_ClassificationItem>&           items
        );
    

 

Parameters

systemGuid
[in] The guid of the classification system whose root items should be retrieved.
items
[out] The retrieved root classification items of the referenced system.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The systemGuid did not refer to a valid classification system.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions