Generates an IFC Difference based on the input parameters.
GSErrCode ACAPI_IFC_GetIFCDifferenceState ( const API_Guid& viewGuid, const API_IFCTranslatorIdentifier& ifcTranslatorIdentifier, API_IFCDifferenceGeneratorState& ifcDifferenceState );
Parameters
- viewGuid
- [in] Is a unique identifier of the View, which will be used for state generation.
- ifcTranslatorIdentifier
- [in] IFC Export Translator identifier.
- ifcDifferenceState
- [out] The resulting IFC Difference State.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- Invalid view Guid or IFC Translator.
For other common API errors see the API Errors document.
Remarks
It generates an IFC Difference State.
Requirements
- Version: API 26 or later
- Header: APIdefs_IFC.h
See Also
ACAPI_IFC_GetIFCDifferenceACAPI_IFC_InvokeIFCDifferenceExportSettingsDlg