ACAPI_​Element_​SetIFCClassificationReference

Set IFC classificationreference of an element

    GSErrCode  ACAPI_Element_SetIFCClassificationReference (
        const API_Guid&                           guid_Element,
        const API_IFCClassificationReference&     classificationReference
    );

 

Parameters

guid_Element
[in] GUID of the element
classificationReference
[in] IFC classificationreference to add or modify.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter or classificationReference is not correct.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function sets the IFC classificationreference of an element.
If a classificationreference with the given referencename already exists for the element, this command will change it.
For a successful setting, the classificationreference must be set correctly explained in the API_IFCClassificationReference structure.
The model may contain GDL objects with APPLICATION_QUERYs which display IFC data. It is the developer’s responsability to refresh the views after modifying IFC data through API functions. See: ACAPI_Automation – APIDo_RebuildID function.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_GetIFCClassificationReferences
ACAPI_Element_RemoveIFCClassificationReference