ACAPI_​AnalyticalModel_​SetElementFromSurfaceLoad

Sets element.type to API_AnalyticalSurfaceLoadID, and element.externalElemData to surfaceLoad.

    GSErrCode  ACAPI_AnalyticalModel_SetElementFromSurfaceLoad (
        const API_AnalyticalSurfaceLoadType&  surfaceLoad
        API_Element&                          element
    );
    

 

Parameters

surfaceLoad
[in] The source for the element.
element
[out] The element to be set.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 26 or later
Header:ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions