APINavigator_​GetNavigatorChildrenItemsID

Retrieves the child items of a navigator item.

    GSErrCode ACAPI_Navigator (
        APINavigator_GetNavigatorChildrenItemsID,
        API_NavigatorItem*            item,
        API_NavigatorItem***          items,
        GS::Array<API_NavigatorItem>* itemsArray
    );

 

Parameters

item
[in] The requested navigator item identified with GUID (optional you should set mapId for performance).
items
[out] Data of the child navigator items (optional parameter)
itemsArray
[out] Same as the items parameter but as a GS::Array (optional parameter)

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The item parameter is nullptr or contains invalid data, or both the items and itemsArray parameters are nullptr.
APIERR_GENERAL
No open project.

 

Remarks

This function is used to get the child items of a given item of the Project Navigator.

Do not forget to dispose the items handle if not needed any more.

 

Example

Refer to the Navigator_Test example project of the API Development Kit.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorItem
APINavigator_GetNavigatorItemID
APINavigator_GetNavigatorParentItemID
ACAPI_Navigator
API Functions