Converts an Analytical Link that is associative to a Curve Member or an edge of a Surface Member (known as a “shortest” Analytical Link) to an Analytical Link that is connected to a fixed coordinate.
GSErrCode ACAPI_AnalyticalModel_ConvertAnalyticalLinkToNonShortest ( const API_Guid& amGuid, const API_Guid& elemGuid, API_AnalyticalLinkType* api_analyticalLink );
Parameters
- amGuid
- [in] The unique identifier of the internal Structural Analytical Model.
- elemGuid
- [in] The unique identifier of the Analytical Link element.
- api_analyticalLink
- [out] The converted Analytical Link.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Requirements
- Version: API 24 or later
- Header: .\ACAPI_Analytical_Adapter.hpp