ACAPI_​Classification_​GetClassificationItemParent

Retrieves the parent of a classification item.

        GSErrCode  ACAPI_Classification_GetClassificationItemParent (
            const API_Guid&              itemGuid,
            API_ClassificationItem&      parent
        );
    

 

Parameters

itemGuid
[in] The guid of the item whose parent should be retrieved.
parent
[out] The retrieved parent classification item. Will be an empty classification item, with null guid, if the specified item doesn’t have a parent.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The itemGuid did not refer to a valid classification item.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions